ubuntu14.04 ruby rails アップデート


ubuntu14.04 ruby rails アップデート

rails g devise:views

で生成しようとしたけど
uby のバージョンが古いためエラー

ubuntu ruby アップデート
で検索し
UbuntuにRubyをインストールした話
を参考に

 cd ~/.rbenv/
git pull

で rbenv をアップデート

しかし、これだけで行うと

rbenv install -l 

で表示されるのは
2.3.1 まで

これ以降をインストールしたいのなら
ruby-build のアップデートが必要なので

cd ~/.rbenv/plugins/ruby-build/
git pull

で更新

これで 2.5 までインストールが可能に

 rbenv install 2.5.0

でインストールして
通常使う ruby を 2.5.0 にするため

 rbenv global 2.5.0

あとは RubyGems をアップデートするので

gem update --system

これでできると思ったら
The `rails’ command exists in these Ruby versions:
2.3.0
となってしまう

このため、このメッセージで検索し
Ruby 2.3.0 → 2.4.1 にした時に Rails が動かなくなった.

を参考に

gem install rails

として
rails 再インストール


PDF
カテゴリー: ruby on rails   パーマリンク

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

次のHTML タグと属性が使えます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>